Office

Das Modul Office bindet eine Onlineversion von LibreOffice in die Weboberfläche des IServ-Portalservers ein. Es können Texte, Tabellen und Präsentationen erstellt und bearbeitet werden. Es ist möglich mit mehreren Benutzern gleichzeitig an einer Datei zu arbeiten. Änderungen werden direkt in allen geöffneten Instanzen der Datei angezeigt. Grundsätzlich können alle Dateiformate aus Microsoft Office und LibreOffice bearbeitet werden.

Dateiaktionen

Dateien mit LibreOfficeOnline können auf verschiedene Arten erstellt und geöffnet werden.

Auf der Übersichtsseite

Hier können Sie neue Officedateien erstellen oder existierende Dateien aus dem Dateibereich des IServ öffnen und bearbeiten.

../../../_images/overview3.png

Neue Datei erstellen

Klicken Sie je nach zu erstellender Dokumentenart auf Office-Dokument erstellen, Office-Kalkulation erstellen oder Office-Präsentation erstellen.

../../../_images/new-1.png

Geben Sie einen Namen ein und navigieren nach einem Klick auf *Ordner wählen* zum gewünschten Ordner in welchem Sie die neue Datei speichern möchten. Um eine Datei mit mehreren Personen zu bearbeiten muss sie entsprechend in einem Gruppenordner abgelegt sein auf den alle Benutzer Zugriff haben.

../../../_images/folderpath.png

Klicken Sie dann auf *Diesen Ordner auswählen* und dannach auf *Erstellen*.

Die neue Datei wird dann direkt zur Bearbeitung geöffnet.

Vorhandene Datei öffen

Klicken erst auf Dokument öffnen und dann auf Datei wählen. Suchen Sie nun die gewünschte Datei aus dem Dateisystem des Iserv heraus und klicken sie an. Klicken Sie dann auf Öffnen.

Im Dateibereich

Erstellen einer neuen Datei

Navigieren Sie zu Organisation -> Dateien und dort in den entsprechenden Dateiordner unter Eigene oder Gruppen. Klicken Sie dann auf *Neues Element*. Wählen Sie in der Auswahlliste das zu erstellende Dateiformat, Office-Dokument, Office-Kalkulation oder Office-Präsentation aus. Geben Sie einen Namen für die neue Datei ein und klicken dann auf *Erstellen*.

../../../_images/office_create.png

Die neue Datei wird nun im Dateibereich erstellt und angezeigt. Um eine Datei mit mehreren Personen zu bearbeiten muss sie entsprechend in einem Gruppenordner abgelegt sein auf den alle Benutzer Zugriff haben.

Öffnen und Bearbeiten einer Datei

Klicken Sie neben der Datei auf *Dateiaktionen* und wählen dann In Office bearbeiten aus.

../../../_images/edit_in_office.png

Datei aus E-Mail oder Foren öffnen

Aus diesen Bereichen können Dateien auf direktem Weg nur zur Ansicht geöffnet werden.

../../../_images/show_in_office.png

Nach einem Klick auf In Office anzeigen öffnet sich ein Vorschaufenster mit dem Inhalt der Datei.

../../../_images/preview1.png

Wollen Sie die Datei bearbeiten, müssen Sie die Datei erst durch klicken auf *Anhang in den Dateibereich kopieren* im Dateibereich sichern. Klicken Sie zunächst auf *Ordner wählen* und navigieren zum entsprechenden Speicherort an dem Sie die Datei ablegen möchten. Bestätigen Sie Ihre Auswahl dann mit *Diesen Ordner auswählen*. Nun müssen Sie noch auf *Speichern* klicken. Oben wird Ihnen nun die folgende Meldung eingeblendet:

../../../_images/save_info.png

Sie können die Datei nun durch einen Klick auf Kopie dieses Anhangs in Office bearbeiten zum bearbeiten öffnen.

Officefunktionen

Grundsätzlich bietet auch die Onlineversion von LibreOffice die selben Funktionen wie die Versionen die auf einem Rechner lokal installiert werden. Im folgenden wird daher nur auf die Besonderheiten eingegangen.

Datei-Menü

Hier finden Sie die folgenden Optionen:

  • Drucken: Hiermit wird eine pdf-Version der Datei zum Download bereitgestellt. Diese kann dann auf das Endgerät heruntergeladen und gedruckt werden.
  • Herunterladen als: Hiermit kann die Datei in den gängigen Officeformaten auf das Endgerät heruntergeladen werden.
  • Eigenschaften...: Unter dem Tab Sicherheit haben Sie die Möglichkeit die Option Änderungen aufzeichnen auszuwählen und dann nach einem Klick auf Schützen das deaktivieren der Option mit einem Passwort zu schützen. Dies ist vor allem dann interessant wenn Sie das Dokument mit mehreren Personen bearbeiten möchten.

Bearbeiten-Menü

  • Reparieren: Diese Funktion ist dazu gedacht, das Änderungen die von anderen Benutzern an dem Dokument vorgenommen wurden entsprechende wieder Rückgängig gemacht werden können. Wichtig ist dabei, daß die Option Bearbeiten -> Änderungen verfolgen -> Aufzeichnen zuvor aktiviert wurde. Siehe auch unter Datei-Menü.

Kollaborative Bearbeitung

Bei einer Datei, die von mehreren Benutzern bearbeitet wird, sollte immer die Option Änderungen aufzeichnen aktiviert und das deaktivieren mit einem Passwort geschützt sein.

Sobald ein Benutzer an dem Dokument Veränderungen vornimmt, erscheint neben dem Dokument ein kleines Infofenster mit dem Namen des Benutzers, einer Kurzbeschriebung der Änderungen und das Datum wann die Änderung vorgenommen wurde.

../../../_images/work.png

Klicken Sie dieses Fenster an, wird zur entsprechenden Textstelle gesprungen und diese hervorgehoben.

../../../_images/select_note.png

Mit den drei Symbolen können Sie die Änderungen annehmen oder ablehnen sowie einen Kommentar hinterlassen. Hat der Benutzer Teile des Textes gelöscht, so werden diese Löschungen vorerst durch das Durchstreichen des Textes angezeigt. Erst wenn die Änderungen am Text bestätigt wurden, wird der zu löschende Text auch wirklich entfernt.